Herramientas en Excel

Duplicados en Excel: 驴C贸mo detectarlos de un vistazo?

Raymundo Ycaza
#Edici贸n de Datos#F贸rmulas#Funciones#Presentaci贸n#Trucos de Excel#馃 Automatizaci贸n con Excel

Seguramente has trabajado con alguna columna en nuestra Hoja de Trabajo, en la que no se deben repetir datos. Por supuesto que llevar este control 鈥渁l ojo鈥 es tedioso y muy poco confiable.

Para ayudarte con este tema, hoy te muestro dos t茅cnicas para detectar valores duplicados en Excel.

Forma #1

Utilizando una columna auxiliar, utiliza la siguiente f贸rmula para detectar los valores que est谩n repetidos.

F贸rmula en ingl茅s:

=IF(COUNTIF($A$1:A1,A2), 鈥淩epetido鈥, 鈥淥k鈥 )

F贸rmula en espa帽ol:

=SI(CONTAR.SI($A$1:A1;A2);鈥淩epetido鈥;鈥淥k鈥)

Supongamos que tienes tus datos en la columna A. Para poder detectar los duplicados, utilizar谩s la columna B como auxiliar e ingresar谩s la siguiente f贸rmula en la celda B2.

Insertando f贸rmula para detectar duplicados

Ahora copiar谩s la celda B2 hacia abajo, hasta donde te sea necesario:

La f贸rmula en acci贸n

Nota: Para adaptarlo a tu archivo, debes cambiar $A$1:A1,A2 por la ubicaci贸n de tus datos a validar.

Forma #2

Utilizando Formato Condicional.

Si no quieres utilizar una columna auxiliar, puedes hacer uso del Formato Condicional para resaltar con color aquellas celdas que est谩n duplicadas.

Para 茅sto, utilizaremos una variante de la f贸rmula anterior:

F贸rmula en ingl茅s:

=COUNTIF($A$1:A1,A2)

F贸rmula en espa帽ol:

=CONTAR.SI($A$1:A1;A2)

Utilizando el mismo caso, en que tienes tus datos en la columna A, seleccionaremos todas las celdas de dicha columna y aplicaremos el Formato Condicional, utilizando la f贸rmula indicada, tal y como te muestro en la siguiente imagen:

Detectando duplicados con el Formato Condicional en Excel

Nota: Para adaptarlo a tu archivo, debes cambiar $A$1:A1,A2 por la ubicaci贸n de tus datos a validar.

隆Listo! Ah铆 tienes dos formas para detectar duplicados en Excel. Espero que lo apliques a tu archivo y te resulte de utilidad.

Cr茅ditos foto: http://www.flickr.com/photos/popilop/331357312/

鈫 Regresar al Blog